I was able to replicate the issue. Thank you.

It's a function of the forum display style/theme. Try this:

Click on your username on the top right.
Select "Preferences"
Choose a different theme under "Your Preferred Forum Style (aka Skin/Theme)"
For example, I was able to see a clear cursor in the reply box with the "new light" theme.